use strict;
my $str = 'log.info(
`DEBUG other strings...
);
log.info(
`remove this instruction!!!
);
log.info(
`DEBUG other strings...
);
log.info(`remove this instruction!!!);
log.info(`DEBUG other strings...);
log.info(
`other strings DEBUG...
);';
my $regex = qr/\blog\.(?:info|warn|error)\((?!\s*`DEBUG\b)[\w\W]*?\);/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}