re = /\blog\.(?:info|warn|error)\((?!\s*`DEBUG\b)[\w\W]*?\);/m
str = 'log.info(
`DEBUG other strings...
);
log.info(
`remove this instruction!!!
);
log.info(
`DEBUG other strings...
);
log.info(`remove this instruction!!!);
log.info(`DEBUG other strings...);
log.info(
`other strings DEBUG...
);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end