# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<varname>\$[a-z_]\w*) \s*\[\s* (?<index>[a-z_]\w*) \s*\]/${varname}['${index}']/gix;t' <<< "$foo[ something ]
$bar[]
$_hehe [lol]"