package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?<varname>\$[a-z_]\w*) \s*\[\s* (?<index>[a-z_]\w*) \s*\]`)
var str = `$foo[ something ]
$bar[]
$_hehe [lol]`
var substitution = "${varname}['${index}']"
fmt.Println(re.ReplaceAllString(str, substitution))
}