$re = '/(?<varname>\$[a-z_]\w*) \s*\[\s* (?<index>[a-z_]\w*) \s*\]/ix';
$str = '$foo[ something ]
$bar[]
$_hehe [lol]';
$subst = "${varname}['${index}']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;