// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ix)(?<varname>\$[a-z_]\w*) \s*\[\s* (?<index>[a-z_]\w*) \s*\]").unwrap();
let string = "$foo[ something ]
$bar[]
$_hehe [lol]";
let substitution = "${varname}['${index}']";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}