import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<varname>\\$[a-z_]\\w*) \\s*\\[\\s* (?<index>[a-z_]\\w*) \\s*\\]";
final String string = "$foo[ something ]\n"
+ "$bar[]\n"
+ "$_hehe [lol]";
final String subst = "${varname}['${index}']";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}