re = /(?<varname>\$[a-z_]\w*) \s*\[\s* (?<index>[a-z_]\w*) \s*\]/ix
str = '$foo[ something ]
$bar[]
$_hehe [lol]'
subst = '${varname}[\'${index}\']'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result