import re
regex = re.compile(r"""
(?<varname>\$[a-z_]\w*) \s*\[\s* (?<index>[a-z_]\w*) \s*\]
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = ("$foo[ something ]\n"
"$bar[]\n"
"$_hehe [lol]")
subst = "${varname}['${index}']"
result = regex.sub(subst, test_str)
if result:
print(result)