import Foundation
let pattern = #"(?<varname>\$[a-z_]\w*) \s*\[\s* (?<index>[a-z_]\w*) \s*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
$foo[ something ]
$bar[]
$_hehe [lol]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${varname}['${index}']"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)