package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\newcommand{\\(.*?)}(\[(\d)\])?{(.+)}`)
var str = `\newcommand{\vA}{\mathbf{A}} % Vanilla command
\newcommand{\Exp}[2]{\mathop{\mathbb{E}}_{#1}\left[#2\right]} % Arguments
\newcommand{\Expect}[2][]{\mathop{\mathbb{E}}_{#1}\left[#2\right]} % Optional Argument
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}