const regex = /\\newcommand{\\(.*?)}(\[(\d)\])?{(.+)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\newcommand{\\\\(.*?)}(\\[(\\d)\\])?{(.+)}', 'gm')
const str = `\\newcommand{\\vA}{\\mathbf{A}} % Vanilla command
\\newcommand{\\Exp}[2]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Arguments
\\newcommand{\\Expect}[2][]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Optional Argument
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}