// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\newcommand{\\(.*?)}(\[(\d)\])?{(.+)}").unwrap();
let string = "\\newcommand{\\vA}{\\mathbf{A}} % Vanilla command
\\newcommand{\\Exp}[2]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Arguments
\\newcommand{\\Expect}[2][]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Optional Argument
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}