$re = '/\\\\newcommand{\\\\(.*?)}(\[(\d)\])?{(.+)}/m';
$str = '\\newcommand{\\vA}{\\mathbf{A}} % Vanilla command
\\newcommand{\\Exp}[2]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Arguments
\\newcommand{\\Expect}[2][]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Optional Argument
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);