import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\newcommand\\{\\\\(.*?)\\}(\\[(\\d)\\])?\\{(.+)\\}";
final String string = "\\newcommand{\\vA}{\\mathbf{A}} % Vanilla command\n"
+ "\\newcommand{\\Exp}[2]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Arguments\n"
+ "\\newcommand{\\Expect}[2][]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Optional Argument\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}