import re
regex = re.compile(r"\\newcommand{\\(.*?)}(\[(\d)\])?{(.+)}", flags=re.MULTILINE)
test_str = ("\\newcommand{\\vA}{\\mathbf{A}} % Vanilla command\n"
"\\newcommand{\\Exp}[2]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Arguments\n"
"\\newcommand{\\Expect}[2][]{\\mathop{\\mathbb{E}}_{#1}\\left[#2\\right]} % Optional Argument\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")