#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z\d_]{4,16}$"
Local $sString = "asddsa" & @CRLF & _
"a" & @CRLF & _
"Hass" & @CRLF & _
"Hasd_12assssssasasasasasaasasasasas" & @CRLF & _
"" & @CRLF & _
"____" & @CRLF & _
"012" & @CRLF & _
"p1pp1" & @CRLF & _
"asd43 34" & @CRLF & _
"asd43_34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")