using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z\d_]{4,16}$";
string input = @"asddsa
a
Hass
Hasd_12assssssasasasasasaasasasasas
____
012
p1pp1
asd43 34
asd43_34";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}