import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z\\d_]{4,16}$";
final String string = "asddsa\n"
+ "a\n"
+ "Hass\n"
+ "Hasd_12assssssasasasasasaasasasasas\n\n"
+ "____\n"
+ "012\n"
+ "p1pp1\n"
+ "asd43 34\n"
+ "asd43_34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}