re = /^[a-z\d_]{4,16}$/m
str = 'asddsa
a
Hass
Hasd_12assssssasasasasasaasasasasas
____
012
p1pp1
asd43 34
asd43_34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end