package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z\d_]{4,16}$`)
var str = `asddsa
a
Hass
Hasd_12assssssasasasasasaasasasasas
____
012
p1pp1
asd43 34
asd43_34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}