import re
regex = re.compile(r"^[a-z\d_]{4,16}$", flags=re.MULTILINE)
test_str = ("asddsa\n"
"a\n"
"Hass\n"
"Hasd_12assssssasasasasasaasasasasas\n\n"
"____\n"
"012\n"
"p1pp1\n"
"asd43 34\n"
"asd43_34")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")