// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z\d_]{4,16}$").unwrap();
let string = "asddsa
a
Hass
Hasd_12assssssasasasasasaasasasasas
____
012
p1pp1
asd43 34
asd43_34";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}