const regex = /^[a-z\d_]{4,16}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z\\d_]{4,16}$', 'gm')
const str = `asddsa
a
Hass
Hasd_12assssssasasasasasaasasasasas
____
012
p1pp1
asd43 34
asd43_34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}