#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)0*(?|(1[10]{6})|([10]{6}1))"
Local $sString = "10" & @CRLF & _
"1111100" & @CRLF & _
"1000000" & @CRLF & _
"11110000000" & @CRLF & _
"111111111111" & @CRLF & _
"000000001111" & @CRLF & _
"000011110000" & @CRLF & _
"00000000111100" & @CRLF & _
"000000001111000" & @CRLF & _
"0000000011110000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")