const regex = /0*(?|(1[10]{6})|([10]{6}1))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0*(?|(1[10]{6})|([10]{6}1))', 'gm')
const str = `10
1111100
1000000
11110000000
111111111111
000000001111
000011110000
00000000111100
000000001111000
0000000011110000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}