# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"0*(?|(1[10]{6})|([10]{6}1))"
test_str = ("10\n"
"1111100\n"
"1000000\n"
"11110000000\n"
"111111111111\n"
"000000001111\n"
"000011110000\n"
"00000000111100\n"
"000000001111000\n"
"0000000011110000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.