import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0*(?|(1[10]{6})|([10]{6}1))";
final String string = "10\n"
+ "1111100\n"
+ "1000000\n"
+ "11110000000\n"
+ "111111111111\n"
+ "000000001111\n"
+ "000011110000\n"
+ "00000000111100\n"
+ "000000001111000\n"
+ "0000000011110000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}