package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0*(?|(1[10]{6})|([10]{6}1))`)
var str = `10
1111100
1000000
11110000000
111111111111
000000001111
000011110000
00000000111100
000000001111000
0000000011110000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}