# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^1?(0*11+)*0*1?$/$1$2$3/gm;t' <<< "accepts:
001
0
1
1110011
100110
001100
rejects:
010
111010
01000000"