const regex = /^1?(0*11+)*0*1?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^1?(0*11+)*0*1?$', 'gm')
const str = `accepts:
001
0
1
1110011
100110
001100
rejects:
010
111010
01000000`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);