package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1?(0*11+)*0*1?$`)
var str = `accepts:
001
0
1
1110011
100110
001100
rejects:
010
111010
01000000`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}