using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1?(0*11+)*0*1?$";
string substitution = @"$1$2$3";
string input = @"accepts:
001
0
1
1110011
100110
001100
rejects:
010
111010
01000000";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}