$re = '/^1?(0*11+)*0*1?$/m';
$str = 'accepts:
001
0
1
1110011
100110
001100
rejects:
010
111010
01000000';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;