#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)\r?\n[^\S\r\n]+Uploaded on"
Local $sString = "" & @CRLF & _
" Update Your Profile to Dissolve This Message" & @CRLF & _
"Social Media Learning and behaviour" & @CRLF & _
" Uploaded on May 3, 2020 at 10:56 in Research" & @CRLF & _
" View Forum" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")