$re = '/(.*)\r?\n[^\S\r\n]+Uploaded on/m';
$str = '
Update Your Profile to Dissolve This Message
Social Media Learning and behaviour
Uploaded on May 3, 2020 at 10:56 in Research
View Forum
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);