re = /(.*)\r?\n[^\S\r\n]+Uploaded on/m
str = '
Update Your Profile to Dissolve This Message
Social Media Learning and behaviour
Uploaded on May 3, 2020 at 10:56 in Research
View Forum
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end