using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\r?\n[^\S\r\n]+Uploaded on";
string input = @"
Update Your Profile to Dissolve This Message
Social Media Learning and behaviour
Uploaded on May 3, 2020 at 10:56 in Research
View Forum
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}