package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\r?\n[^\S\r\n]+Uploaded on`)
var str = `
Update Your Profile to Dissolve This Message
Social Media Learning and behaviour
Uploaded on May 3, 2020 at 10:56 in Research
View Forum
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}