import re
regex = re.compile(r"(.*)\r?\n[^\S\r\n]+Uploaded on", flags=re.MULTILINE)
test_str = ("\n"
" Update Your Profile to Dissolve This Message\n"
"Social Media Learning and behaviour\n"
" Uploaded on May 3, 2020 at 10:56 in Research\n"
" View Forum\n"
" \n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")