#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(?!\A)\G|(Fig))([\d.]*)(?<=[ .])[ ]"
Local $sString = " Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds"
Local $sSubst = "$1$2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)