const regex = /(?:(?!\A)\G|(Fig))([\d.]*)(?<=[ .])[ ]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?!\\A)\\G|(Fig))([\\d.]*)(?<=[ .])[ ]', 'g')
const str = ` Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds`;
const subst = `$1$2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);