use strict;
my $str = ' Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds';
my $regex = qr/(?:(?!\A)\G|(Fig))([\d.]*)(?<=[ .])[ ]/p;
my $subst = '$1$2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";