re = /(?:(?!\A)\G|(Fig))([\d.]*)(?<=[ .])[ ]/
str = ' Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds'
subst = '$1$2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result