import Foundation
let pattern = #"(?:(?!\A)\G|(Fig))([\d.]*)(?<=[ .])[ ]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)