import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?!\\A)\\G|(Fig))([\\d.]*)(?<=[ .])[ ]";
final String string = " Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds";
final String subst = "$1$2 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}