using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?!\A)\G|(Fig))([\d.]*)(?<=[ .])[ ]";
string substitution = @"$1$2 ";
string input = @" Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}