$re = '/(?:(?!\A)\G|(Fig))([\d.]*)(?<=[ .])[ ]/';
$str = ' Fig. 1. sasasa Fig. 34. 345 dffdfd etc. dsds';
$subst = "$1$2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;