using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z0-9]+[.\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+";
string input = @"<i><b>YudV@lol.ru</b></i></a>
ОМ ПО ЭЛ. ПОЧТЕ: \rCO-O.KI-ES@lol.RU\r.\r\nОМ ПО ЭЛ. ПОЧТЕ: \rCOOKIES@lol.RU\r.\r\n
ОМ ПО ЭЛ. ПОЧТЕ: \nCO-O.KI-ES@lol.RU\r.\r\nОМ ПО ЭЛ. ПОЧТЕ: \sCOOKIES@lol.RU\r.\r\n";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}