$re = '/([A-Za-z0-9]+[.\-_])*[A-Za-z0-9]+@[A-Za-z0-9-]+(.[A-Z|a-z]{2,})+/sim';
$str = '<i><b>YudV@lol.ru</b></i></a>
ОМ ПО ЭЛ. ПОЧТЕ: \\rCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\rCOOKIES@lol.RU\\r.\\r\\n
ОМ ПО ЭЛ. ПОЧТЕ: \\nCO-O.KI-ES@lol.RU\\r.\\r\\nОМ ПО ЭЛ. ПОЧТЕ: \\sCOOKIES@lol.RU\\r.\\r\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);